summaryrefslogtreecommitdiffstats
path: root/src/tools/bootstrap/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-12-09 09:37:22 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-12-09 22:12:17 +0100
commit88fe9d3d977b865802085fbd6b5a43dbb39b116d (patch)
treee0ac2a195a852ca131a1885aa47917024adda2b3 /src/tools/bootstrap/CMakeLists.txt
parent4a1091f489ac3fee9efd81b0f1ffca4275725610 (diff)
CMake: Fix FEATURE_static_runtime build
We must call qt_set_common_target_properties on Bootstrap too, because that's were FEATURE_static_runtime is handled. Change-Id: Ie54f7d599d0c3a54b761e6c679983b475e77c17d Pick-to: 6.0 Fixes: QTBUG-89201 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Eric Lemanissier <eric.lemanissier@gmail.com>
Diffstat (limited to 'src/tools/bootstrap/CMakeLists.txt')
-rw-r--r--src/tools/bootstrap/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/tools/bootstrap/CMakeLists.txt b/src/tools/bootstrap/CMakeLists.txt
index 218d634683..75f2d3ee4b 100644
--- a/src/tools/bootstrap/CMakeLists.txt
+++ b/src/tools/bootstrap/CMakeLists.txt
@@ -267,6 +267,7 @@ qt_internal_apply_gc_binaries(Bootstrap PUBLIC)
set_target_properties(Bootstrap PROPERTIES AUTOMOC OFF AUTOUIC OFF AUTORCC OFF)
qt_internal_add_target_aliases(Bootstrap)
qt_set_msvc_cplusplus_options(Bootstrap PUBLIC)
+qt_set_common_target_properties(Bootstrap)
qt_internal_apply_intel_cet(Bootstrap PUBLIC)
qt_internal_extend_target(Bootstrap CONDITION MSVC