summaryrefslogtreecommitdiffstats
path: root/src/xml/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2018-10-24 15:20:27 +0200
committerTobias Hunger <tobias.hunger@qt.io>2018-11-01 11:48:46 +0000
commite9c45bbdddd4df005bdaa5eea9740d351e6eaea2 (patch)
tree23765d4650f8f349d1f32e0fe4b1bc678cae7568 /src/xml/CMakeLists.txt
parent345e6b0213b1273b698163064f80d33bc7ce64a9 (diff)
Begin port of qtbase to CMake
Done-by: Alexandru Croitor <alexandru.croitor@qt.io> Done-by: Frederik Gladhorn <frederik.gladhorn@qt.io> Done-by: Kevin Funk <kevin.funk@kdab.com> Done-by: Mikhail Svetkin <mikhail.svetkin@qt.io> Done-by: Simon Hausmann <simon.hausmann@qt.io> Done-by: Tobias Hunger <tobias.hunger@qt.io> Done-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Done-by: Volker Krause <volker.krause@kdab.com> Change-Id: Ida4f8bd190f9a4849a1af7b5b7981337a5df5310 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Mikhail Svetkin <mikhail.svetkin@qt.io>
Diffstat (limited to 'src/xml/CMakeLists.txt')
-rw-r--r--src/xml/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/xml/CMakeLists.txt b/src/xml/CMakeLists.txt
new file mode 100644
index 0000000000..ae045ae76e
--- /dev/null
+++ b/src/xml/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from xml.pro.
+
+#####################################################################
+## QtXml Module:
+#####################################################################
+
+add_qt_module(Xml
+ SOURCES
+ dom/qdom.cpp dom/qdom.h
+ qtxmlglobal.h
+ sax/qxml.cpp sax/qxml.h sax/qxml_p.h
+ DEFINES
+ QT_NO_USING_NAMESPACE
+ QT_NO_FOREACH
+ LIBRARIES
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+)
+
+## Scopes:
+#####################################################################
+
+### FIXME
+# extend_target(Xml CONDITION (MSVC) AND (TEST_architecture_arch STREQUAL i386))
+# SOURCES
+# ### FIXME: QMAKE_LFLAGS += /BASE:0x61000000
+# )
+
+add_qt_docs(./doc/qtxml.qdocconf)