summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-04-27 16:17:22 +0200
committerQt by Nokia <qt-info@nokia.com>2012-05-03 16:11:58 +0200
commitb4dabb9e50ce26469b0b7d71e168463abf727334 (patch)
tree65784b98854163ae1b630c3b7c6cd97a533abee1 /tests/auto/cmake/CMakeLists.txt
parent4d4975c3d0a2534a4023239d37ca4d93a8869e66 (diff)
Revert "Don't use the pri depends line for link dependencies."
This reverts commit df43b9a06a73759ba74f23d9c3e91bd0347d1026. Using the same depends information as QMake provides adds a lot of convenience for users, and is mostly 'correct' from a CMake point of view anyway. Change-Id: I8f2a2f74a687c25a0dedcc491ef72ddb5b136090 Reviewed-by: Alexander Neundorf <neundorf@kde.org> Reviewed-by: Clinton Stimpson <clinton@elemtech.com> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index b9b0e8c605..dfcb225555 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -85,8 +85,7 @@ else()
message("CMake version older than 2.8.7 (Found ${CMAKE_VERSION}). Not running test \"pass1\"")
endif()
expect_pass(pass2)
-# Modules do not currently find their own dependencies.
-# expect_pass(pass3)
+expect_pass(pass3)
expect_fail(fail4)
expect_fail(fail5)
expect_pass("pass(needsquoting)6")