summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-10-02 12:04:00 +0200
committerThe Qt Project <gerrit-noreply@qt-project.org>2012-10-04 11:58:48 +0200
commitd24b867e56e7e4519185f37c12f02bcebd1c31f2 (patch)
tree1cf005b48cfdcde8f9a0ed8e8af2ca2ae3ce0a3a /tests/auto/cmake/CMakeLists.txt
parent595deca5c909d99a8cd157b9fb6c82c64b1db1f5 (diff)
CMake: Improve QT5_GET_MOC_FLAGS macro
We need to handle CMAKE_INCLUDE_CURRENT_DIR for include directories. Otherwise generated files located in the current binary directory are not found as expected. e.g. *.json file as meta data for Qt5's plugins generated at build time. Change-Id: I14ae1e7013f9d8b485aa990d50db4a03ca4f4b81 Reviewed-by: Yuchen Deng <loaden@gmail.com> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 1fe6ed14c4..9571502552 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -78,6 +78,7 @@ endif()
expect_pass(test_private_includes)
expect_pass(test_modules)
expect_pass(test_testlib_definitions)
+expect_pass(test_json_plugin_includes)
expect_fail(test_testlib_no_link_gui)
expect_fail(test_testlib_no_link_widgets)