summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-10-29 15:46:26 +0100
committerThe Qt Project <gerrit-noreply@qt-project.org>2012-10-31 07:16:03 +0100
commit03b9b423b07a21916b8204047dbc34bf74f914fe (patch)
tree093b850fae8648ce2973bc7e9052a54cf17ed929 /tests/auto/cmake/CMakeLists.txt
parent21d74702d18b2aa745ea847b5aa0fb1c970df817 (diff)
Generate instances of types in the CMake tests.
All modules currently have a test_modules CMake test. The new module_includes test has very similar requirements, and can obsolete the hand-maintained test_modules tests in all modules. After all test_modules have been removed in other repos, the module_includes test can be renamed to that name. The types chosen need to have a constructor which can be invoked with no arguments. QtConcurrent has no public classes which fit that description so it is still tested separately Change-Id: Id7929cd32b3112c293cbf5e6964cc894a697f9b1 Reviewed-by: Rohan McGovern <rohan.mcgovern@nokia.com>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 367832efb6..46dcdcca2b 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -74,7 +74,6 @@ if (NOT WIN32)
expect_pass(test_add_resources_delayed_file)
endif()
expect_pass(test_private_includes)
-expect_pass(test_modules)
expect_pass(test_testlib_definitions)
expect_pass(test_json_plugin_includes)
@@ -92,23 +91,23 @@ execute_process(COMMAND ${CMAKE_COMMAND} -E copy
set(qt_module_includes
Core QObject
- Concurrent QtConcurrentRun
Gui QImage
Widgets QWidget
Network QHostInfo
- OpenGL QGLContext
+ OpenGL QGLBuffer
Sql QSqlError
- Test QSignalSpy
+ Test QTestEventList
Xml QDomDocument
PrintSupport QPrintDialog
)
if (UNIX AND NOT APPLE AND NOT QNXNTO)
list(APPEND qt_module_includes
- DBus QDBusConnection
+ DBus QDBusMessage
)
endif()
test_module_includes(
${qt_module_includes}
)
+expect_pass(test_concurrent_module)