summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-03-29 15:28:16 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-04-12 17:19:41 +0200
commitfcb766f58887023f5e8667cd704b7bfe75fc56ad (patch)
treee78d3e14fcf34c208ad90f8b09f2d8ec64547982 /tests/auto/cmake/CMakeLists.txt
parentb1fe3e3d80cb23dee4de683e03711d1ac0614de2 (diff)
Add test of the static plugin with resources
The test follows up the discussion about tests related to the static plugin resources: https://codereview.qt-project.org/c/qt/qtbase/+/341203/6/tests/auto/other/init_resources_static_plugin/CMakeLists.txt#1 It emulates the static plugin that contains resource files. Since the test already exposed few issues related to the resource object linking it makes sense to have it in test set. Change-Id: I62621c2db1eae6ae5842ba52035774a662d93423 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index a94f1a51fe..acb7253731 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -216,3 +216,5 @@ _qt_internal_test_expect_pass(test_add_resources_binary_generated
BINARY test_add_resources_binary_generated)
include(test_plugin_shared_static_flavor.cmake)
+_qt_internal_test_expect_pass(test_init_resources_static_plugin
+ BINARY test_init_resources_static_plugin)