summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/pass3/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-04-18 16:46:26 +0200
committerQt by Nokia <qt-info@nokia.com>2012-04-23 17:03:56 +0200
commit61c433785eb918d81b927f17bcad4687f2269afe (patch)
treebce4d94e963b4dd0f8fe73a19b5cd764a33b2627 /tests/auto/cmake/pass3/CMakeLists.txt
parentf88212c22f7e4bec261130a6f82294adfc75abca (diff)
Move the CMake unit tests to auto/
This will allow the CI system to run the tests. The tests are only run if cmake is found. Change-Id: Ie73a56114c151871160bafcbf0b90b2d54620855 Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@nokia.com> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com> Reviewed-by: Sergio Ahumada <sergio.ahumada@nokia.com>
Diffstat (limited to 'tests/auto/cmake/pass3/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/pass3/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/cmake/pass3/CMakeLists.txt b/tests/auto/cmake/pass3/CMakeLists.txt
new file mode 100644
index 0000000000..7fa6731f9b
--- /dev/null
+++ b/tests/auto/cmake/pass3/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(pass3)
+
+# The module finds its dependencies
+find_package(Qt5Widgets REQUIRED)
+
+include_directories(${Qt5Widgets_INCLUDE_DIRS})
+
+add_definitions(${Qt5Core_DEFINITIONS})
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+qt5_wrap_cpp(moc_files mywidget.h)
+qt5_wrap_ui(ui_files mywidget.ui)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")
+
+add_executable(mywidget mywidget.cpp ${moc_files} ${ui_files})
+target_link_libraries(mywidget ${Qt5Widgets_LIBRARIES})