summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_add_resource_options/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-06-22 10:04:05 +0200
committerQt by Nokia <qt-info@nokia.com>2012-06-23 11:37:49 +0200
commit2af438a6ce31f225f0d1c0b1b43df848a858fe18 (patch)
tree7fc4e597f0de0ae6564f64758fccdf324ff87a2a /tests/auto/cmake/test_add_resource_options/CMakeLists.txt
parentddf5226bd7e120a5ef6fdf5fb82be36a48844cb7 (diff)
Give the CMake unit tests more meaningful names.
Change-Id: I0a54d32ec62ff6daf7672d0aabdeb038f4c7c78f Reviewed-by: David Faure <faure@kde.org>
Diffstat (limited to 'tests/auto/cmake/test_add_resource_options/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_add_resource_options/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_add_resource_options/CMakeLists.txt b/tests/auto/cmake/test_add_resource_options/CMakeLists.txt
new file mode 100644
index 0000000000..e79b954f3d
--- /dev/null
+++ b/tests/auto/cmake/test_add_resource_options/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(test_add_resource_options)
+
+find_package(Qt5Core REQUIRED)
+
+include_directories(${Qt5Core_INCLUDE_DIRS})
+
+add_definitions(${Qt5Core_DEFINITIONS})
+
+qt5_wrap_cpp(moc_files myobject.h)
+
+# Test options. The -binary option generates a binary to dlopen instead of
+# a source file to compile. The compiler will consider it garbage when used
+# in the add_executable call.
+qt5_add_resources(rcc_files "test_macro_options.qrc" OPTIONS -binary)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
+
+add_executable(myobject myobject.cpp ${moc_files} ${rcc_files})
+target_link_libraries(myobject ${Qt5Core_LIBRARIES})