summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_concurrent_module/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-10-29 15:46:26 +0100
committerThe Qt Project <gerrit-noreply@qt-project.org>2012-10-31 07:16:03 +0100
commit03b9b423b07a21916b8204047dbc34bf74f914fe (patch)
tree093b850fae8648ce2973bc7e9052a54cf17ed929 /tests/auto/cmake/test_concurrent_module/CMakeLists.txt
parent21d74702d18b2aa745ea847b5aa0fb1c970df817 (diff)
Generate instances of types in the CMake tests.
All modules currently have a test_modules CMake test. The new module_includes test has very similar requirements, and can obsolete the hand-maintained test_modules tests in all modules. After all test_modules have been removed in other repos, the module_includes test can be renamed to that name. The types chosen need to have a constructor which can be invoked with no arguments. QtConcurrent has no public classes which fit that description so it is still tested separately Change-Id: Id7929cd32b3112c293cbf5e6964cc894a697f9b1 Reviewed-by: Rohan McGovern <rohan.mcgovern@nokia.com>
Diffstat (limited to 'tests/auto/cmake/test_concurrent_module/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_concurrent_module/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_concurrent_module/CMakeLists.txt b/tests/auto/cmake/test_concurrent_module/CMakeLists.txt
new file mode 100644
index 0000000000..efd7b725ea
--- /dev/null
+++ b/tests/auto/cmake/test_concurrent_module/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(test_concurrent_module)
+
+find_package(Qt5Concurrent REQUIRED)
+
+include_directories(
+ ${Qt5Concurrent_INCLUDE_DIRS}
+)
+
+add_definitions(
+ ${Qt5Concurrent_DEFINITIONS}
+)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
+
+add_executable(mainapp main.cpp)
+
+target_link_libraries(mainapp
+ ${Qt5Concurrent_LIBRARIES}
+)