summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_interface/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2015-05-28 21:20:55 +0200
committerThiago Macieira <thiago.macieira@intel.com>2015-05-29 00:08:41 +0000
commite3983c87280ade48b243d9c60bed639713851be9 (patch)
treec370ee7f6fb9ffaad46501e89b528ed4a0558991 /tests/auto/cmake/test_interface/CMakeLists.txt
parent95b6c4fed6521aa2212cab67cb8a6e5553e86117 (diff)
Revert some changes in light of GCC 4 -fPIE reversalv5.4.2
The -fPIE option is now accepted when using GCC 4, which means it is available for backward compatibility for clients using CMake 2.8.11 or older which makes use of the POSITION_INDEPENDENT_CODE feature. Conditionally use that feature for old versions of cmake with GCC 4. Restore the tests for those versions, and clarify the situation in the ChangeLog. Change-Id: I5a06b155dda7db559d86841a2b34fd8ed95acbd0 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/cmake/test_interface/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_interface/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/cmake/test_interface/CMakeLists.txt b/tests/auto/cmake/test_interface/CMakeLists.txt
index bd3217a497..a8af92da63 100644
--- a/tests/auto/cmake/test_interface/CMakeLists.txt
+++ b/tests/auto/cmake/test_interface/CMakeLists.txt
@@ -1,5 +1,5 @@
-cmake_minimum_required(VERSION 2.8.12)
+cmake_minimum_required(VERSION 2.8.11)
project(test_interface)