summaryrefslogtreecommitdiffstats
path: root/tests/auto/concurrent/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Buhr <andreas.buhr@qt.io>2020-10-09 00:02:00 +0200
committerAndreas Buhr <andreas.buhr@qt.io>2020-11-09 16:01:33 +0100
commit223e409efbf29f7c06bec7a403403c9689f42b3e (patch)
tree005c43d0ac9d33a74af85e5e3e9c0277b19dadd9 /tests/auto/concurrent/CMakeLists.txt
parent3553f8119b5cd8c04c7208c519bb08245a44720e (diff)
Automatically generate unit tests for QtConcurrent
There are many different ways to to call map and filter functions in QtConcurrent. This patch adds a python script to generate all possible combinations. Change-Id: I61ed1758601e219c5852e8cc939c5feebb23d2f6 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jarek Kobus <jaroslaw.kobus@qt.io>
Diffstat (limited to 'tests/auto/concurrent/CMakeLists.txt')
-rw-r--r--tests/auto/concurrent/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/concurrent/CMakeLists.txt b/tests/auto/concurrent/CMakeLists.txt
index 2ef8cfd128..ec8eea76aa 100644
--- a/tests/auto/concurrent/CMakeLists.txt
+++ b/tests/auto/concurrent/CMakeLists.txt
@@ -1,6 +1,7 @@
# Generated from concurrent.pro.
add_subdirectory(qtconcurrentfilter)
+add_subdirectory(qtconcurrentfiltermapgenerated)
add_subdirectory(qtconcurrentiteratekernel)
add_subdirectory(qtconcurrentmap)
add_subdirectory(qtconcurrentmedian)