summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qglobalstatic/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Saario <toni.saario@qt.io>2021-03-03 21:03:25 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-03-07 16:56:12 +0000
commit9c0ba50658d43806cda2c0ba735f373d6c7ad3d9 (patch)
tree847296b1b90e1d6620ccbb2f8b142c8b788d5284 /tests/auto/corelib/global/qglobalstatic/CMakeLists.txt
parent03332d8a000816cc5736a9d65404a3d247b79bed (diff)
Skip globalstatic threadStressTest on QEMU
The test causes frequent failures in the CI. This is the most subtle fix until it is properly fixed. Task-number: QTBUG-91423 Change-Id: I6499378dcd3ed1c31275db38d83b572e764366cc Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io> Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit 49e93b6e3928e12507ec7956d66e79a2555c13a8) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/auto/corelib/global/qglobalstatic/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qglobalstatic/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/corelib/global/qglobalstatic/CMakeLists.txt b/tests/auto/corelib/global/qglobalstatic/CMakeLists.txt
index 959b2b25b0..6f8a784a0d 100644
--- a/tests/auto/corelib/global/qglobalstatic/CMakeLists.txt
+++ b/tests/auto/corelib/global/qglobalstatic/CMakeLists.txt
@@ -12,4 +12,5 @@ qt_internal_add_test(tst_qglobalstatic
SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/\\\"
PUBLIC_LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
)