summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qnumeric/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2021-10-12 13:39:37 -0700
committerThiago Macieira <thiago.macieira@intel.com>2021-10-13 12:49:49 -0700
commitcb0ea3989598a83b2326f63e7da1669018a965e5 (patch)
tree7c2a85ef1ad971e2e653b986457117bf95e25c55 /tests/auto/corelib/global/qnumeric/CMakeLists.txt
parent63d80c7c4b23b5802f1f20e6b322ccf4cdff5b12 (diff)
CMake: remove support for building Qt with the old Intel compiler
This hasn't worked for some time. It's not in our CI and I don't think it was working at all. When I tried to build it, I ran into several problems with C++17 and an Internal Compiler Error I did not have any interest in working around. After discussing with the Intel compiler team, it was decided that fixing those issues in the old compiler is not going to happen. Instead, their recommendation is to adopt the new LLVM-based compiler, which the last commit added support for. This commit does not remove qmake support for the old ICC. It's possible someone is using qmake with a non-Qt6 project and ICC. Change-Id: Icb2516126f674e7b8bb3fffd16ad6350ddbd49e5 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/global/qnumeric/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qnumeric/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/tests/auto/corelib/global/qnumeric/CMakeLists.txt b/tests/auto/corelib/global/qnumeric/CMakeLists.txt
index 0359af03ae..f86ddffc1d 100644
--- a/tests/auto/corelib/global/qnumeric/CMakeLists.txt
+++ b/tests/auto/corelib/global/qnumeric/CMakeLists.txt
@@ -13,14 +13,3 @@ qt_internal_add_test(tst_qnumeric
## Scopes:
#####################################################################
-
-qt_internal_extend_target(tst_qnumeric CONDITION ICC
- COMPILE_OPTIONS
- -fp-model
- strict
-)
-
-qt_internal_extend_target(tst_qnumeric CONDITION intel_icl
- COMPILE_OPTIONS
- /fp:strict
-)