summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 11:53:30 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 17:24:44 +0000
commit76590ce2208e754f87e5b75c0c1de425c34e0b1a (patch)
treed76e16f0a1d211135dcb54c4d2fe344a09c46663 /tests/auto/corelib/io/qfileinfo/CMakeLists.txt
parent681e8b4ead432b2658b0be9f90454bbdbd80d1b1 (diff)
Regenerate tests/auto/corelib/io
Change-Id: Ic1d1b5c0deb90800c7219fb8cce4e77e0db145b8 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'tests/auto/corelib/io/qfileinfo/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qfileinfo/CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/tests/auto/corelib/io/qfileinfo/CMakeLists.txt b/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
index d786378b61..03f2e99e37 100644
--- a/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
+++ b/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
@@ -5,7 +5,6 @@
#####################################################################
add_qt_test(tst_qfileinfo
- GUI
SOURCES
tst_qfileinfo.cpp
LIBRARIES
@@ -13,20 +12,28 @@ add_qt_test(tst_qfileinfo
)
# Resources:
+set(qfileinfo_resource_files
+ "resources/"
+)
+
add_qt_resource(tst_qfileinfo "qfileinfo"
PREFIX
"/tst_qfileinfo/"
FILES
- "resources/"
+ ${qfileinfo_resource_files}
)
+set(testdata_resource_files
+ "resources/file1"
+ "resources/file1.ext1"
+ "resources/file1.ext1.ext2"
+ "tst_qfileinfo.cpp"
+)
+
add_qt_resource(tst_qfileinfo "testdata"
PREFIX
"/testdata"
FILES
- "resources/file1"
- "resources/file1.ext1"
- "resources/file1.ext1.ext2"
- "tst_qfileinfo.cpp"
+ ${testdata_resource_files}
)