summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
diff options
context:
space:
mode:
authorKarsten Heimrich <karsten.heimrich@qt.io>2021-05-11 14:09:11 +0200
committerKarsten Heimrich <karsten.heimrich@qt.io>2021-06-05 01:16:06 +0200
commit0564ebdb3641d7325f73dbbf2cbb04e6dca92d83 (patch)
treea766802e3bd675e8d84d655c3b93a0ea62d98d92 /tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
parenta1d967357f2715899d0236ea4910e615d178024f (diff)
Unify behavior for long path or UNC prefix removal
Split the code out of QDir::fromNativeSeparator into a separate reusable function to remove the above-mentioned prefixes. Fixes and unifies behavior if the prefix was given with slashes instead of backslashes. Add a couple more test cases. Fixes: QTBUG-93868 Pick-to: 5.15 6.0 6.1 Change-Id: Ibd94ae283e2fb113f9c2db97475fbc7d89522bbf Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Oliver Wolff <oliver.wolff@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
index 11d4b991ce..f8419cee87 100644
--- a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
@@ -45,3 +45,8 @@ if(ANDROID AND NOT ANDROID_EMBEDDED)
${android_testdata_resource_files}
)
endif()
+
+qt_internal_extend_target(tst_qtemporaryfile CONDITION WIN32
+ LIBRARIES
+ shlwapi
+)