summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-07 11:17:45 +0200
committerFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-10 12:10:27 +0000
commit06fdea1ce570e0dae86e33f485e429fefacda0fa (patch)
tree6c0aa671543adea088bd738955fd84a78b000a07 /tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt
parentfbace1f4e059dee498332146da0d90c627886952 (diff)
cmake: add corelib/thread/qthreadstorage
Fixes: QTBUG-78221 Change-Id: Icb4614f8187c16e6b13d9db1dbc6adfcd579db43 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt b/tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt
new file mode 100644
index 0000000000..52a928863c
--- /dev/null
+++ b/tests/auto/corelib/thread/qthreadstorage/CMakeLists.txt
@@ -0,0 +1,21 @@
+# special case skip regeneration
+# Generated from qthreadstorage.pro.
+
+#####################################################################
+## tst_qthreadstorage Test:
+#####################################################################
+
+add_qt_test(tst_qthreadstorage
+ SOURCES
+ tst_qthreadstorage.cpp
+ LIBRARIES # special case
+ Threads::Threads # special case
+
+)
+
+## Scopes:
+#####################################################################
+
+if(NOT ANDROID AND NOT WINRT)
+ add_subdirectory(crashonexit)
+endif()