summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbustype/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-07 19:46:57 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-08 12:32:53 +0000
commit0efe6fc90fe964b8be20ca2046e3bfe7a394f3f7 (patch)
treef95d62707d891dcba92d0dbb86dc6113b4678a6e /tests/auto/dbus/qdbustype/CMakeLists.txt
parent0c498ef4ffde8c410ee2d34ef977779e22070122 (diff)
Don't link against dbus-1_nolink when dbus_linked feature is off
dbus1_linked is only evaluated to true when the dbus package is found. If it was not found, then it makes no sense to link against the _nolink target, because no package was found in the first place. When the package is not found, QtDBus uses a minimal dbus header which is included with QtDBus sources, so there is no need for the _nolink target. This amends cc141cc5c61d086d6938e2c7312ec02e5f79734c and fixes a build failure on macOS. Change-Id: I71dcbb7465ad13b0bf03579f51412c373125caba Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'tests/auto/dbus/qdbustype/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbustype/CMakeLists.txt24
1 files changed, 16 insertions, 8 deletions
diff --git a/tests/auto/dbus/qdbustype/CMakeLists.txt b/tests/auto/dbus/qdbustype/CMakeLists.txt
index c76f44ba02..fc0c014a07 100644
--- a/tests/auto/dbus/qdbustype/CMakeLists.txt
+++ b/tests/auto/dbus/qdbustype/CMakeLists.txt
@@ -10,17 +10,25 @@ add_qt_test(tst_qdbustype
LIBRARIES
Qt::CorePrivate
Qt::DBusPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::DBus
)
+#### Keys ignored in scope 1:.:.:qdbustype.pro:<TRUE>:
+# CONFIG = "testcase" "parallel_test"
+
## Scopes:
#####################################################################
-extend_target(tst_qdbustype CONDITION QT_FEATURE_dbus_linked
- DEFINES
- QT_LINKED_LIBDBUS
-)
+ extend_target(tst_qdbustype CONDITION QT_FEATURE_dbus_linked
+ DEFINES
+ QT_LINKED_LIBDBUS
+ LIBRARIES
+ dbus-1
+ )
-extend_target(tst_qdbustype CONDITION NOT QT_FEATURE_dbus_linked
- SOURCES
- ../../../../src/dbus/qdbus_symbols.cpp
-)
+ extend_target(tst_qdbustype CONDITION NOT QT_FEATURE_dbus_linked
+ SOURCES
+ ../../../../src/dbus/qdbus_symbols.cpp
+ )