summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/image/qicon/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-22 10:16:58 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 16:59:06 +0200
commit403213240c7b2dc09378e1cb8c147131e368f90c (patch)
treeff86910332629fe5e2fab59a30fb863a5febb366 /tests/auto/gui/image/qicon/CMakeLists.txt
parente0c62a48b8a826a46a143e57e94b2a0ea73c7cae (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Clean up some stale .prev files that are not needed anymore. Clean up some project files that are not used anymore. Task-number: QTBUG-86815 Change-Id: I9947da921f98686023c6bb053dfcc101851276b5 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/gui/image/qicon/CMakeLists.txt')
-rw-r--r--tests/auto/gui/image/qicon/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/auto/gui/image/qicon/CMakeLists.txt b/tests/auto/gui/image/qicon/CMakeLists.txt
index 48ec1c348c..5f6b139205 100644
--- a/tests/auto/gui/image/qicon/CMakeLists.txt
+++ b/tests/auto/gui/image/qicon/CMakeLists.txt
@@ -30,7 +30,7 @@ file(GLOB_RECURSE test_data_glob
*.svgz)
list(APPEND test_data ${test_data_glob})
-qt_add_test(tst_qicon
+qt_internal_add_test(tst_qicon
SOURCES
tst_qicon.cpp
PUBLIC_LIBRARIES
@@ -69,7 +69,7 @@ set(tst_qicon_resource_files
"tst_qicon.cpp"
)
-qt_add_resource(tst_qicon "tst_qicon"
+qt_internal_add_resource(tst_qicon "tst_qicon"
PREFIX
"/"
FILES
@@ -79,7 +79,7 @@ set(qmake_immediate_resource_files
"tst_qicon.cpp"
)
-qt_add_resource(tst_qicon "qmake_immediate"
+qt_internal_add_resource(tst_qicon "qmake_immediate"
PREFIX
"/"
FILES
@@ -90,7 +90,7 @@ qt_add_resource(tst_qicon "qmake_immediate"
## Scopes:
#####################################################################
-qt_extend_target(tst_qicon CONDITION TARGET Qt::Widgets
+qt_internal_extend_target(tst_qicon CONDITION TARGET Qt::Widgets
PUBLIC_LIBRARIES
Qt::Widgets
)