summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/image/qpixmap/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-07 18:01:06 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 09:38:35 +0200
commite9a328bc0e56b429a370b13c8e0b4790916cebde (patch)
tree059f3b089a8557cb4c45e3dc059b58e020e34dcb /tests/auto/gui/image/qpixmap/CMakeLists.txt
parent5417f1e40cb647c05bffad21493feacac45f193e (diff)
CMake: Regenerate tests with new qt_ prefixed APIs
Use pro2cmake with '--api-version 2' to force regenerate projects to use the new prefixed qt_foo APIs. Change-Id: I055c4837860319e93aaa6b09d646dda4fc2a4069 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/auto/gui/image/qpixmap/CMakeLists.txt')
-rw-r--r--tests/auto/gui/image/qpixmap/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/auto/gui/image/qpixmap/CMakeLists.txt b/tests/auto/gui/image/qpixmap/CMakeLists.txt
index efdfb3b98e..b58609a760 100644
--- a/tests/auto/gui/image/qpixmap/CMakeLists.txt
+++ b/tests/auto/gui/image/qpixmap/CMakeLists.txt
@@ -22,7 +22,7 @@ file(GLOB_RECURSE test_data_glob
images/*)
list(APPEND test_data ${test_data_glob})
-add_qt_test(tst_qpixmap
+qt_add_test(tst_qpixmap
SOURCES
tst_qpixmap.cpp
PUBLIC_LIBRARIES
@@ -83,7 +83,7 @@ set(qpixmap_resource_files
"loadFromData/designer_rgb32.png"
)
-add_qt_resource(tst_qpixmap "qpixmap"
+qt_add_resource(tst_qpixmap "qpixmap"
PREFIX
"/"
FILES
@@ -94,13 +94,13 @@ add_qt_resource(tst_qpixmap "qpixmap"
## Scopes:
#####################################################################
-extend_target(tst_qpixmap CONDITION TARGET Qt::Widgets
+qt_extend_target(tst_qpixmap CONDITION TARGET Qt::Widgets
PUBLIC_LIBRARIES
Qt::Widgets
Qt::WidgetsPrivate
)
-extend_target(tst_qpixmap CONDITION WIN32
+qt_extend_target(tst_qpixmap CONDITION WIN32
PUBLIC_LIBRARIES
gdi32
user32