summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-07 13:18:21 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-08 15:09:54 +0000
commitc51fe841f472edb4af5d56d436fa6df201b2fc9a (patch)
treeb70aee0528842dc3cb3a30df05409191df4fbbe8 /tests/auto/network/CMakeLists.txt
parent3cfaa19c60e43e022e97f5ebe76d70a0610950a6 (diff)
Fix handling of _nolink targets for the QtNetwork module
When a _nolink target is exported, instead of getting the original namespace prefix, it gets the Qt6 prefix (OpenSSL::OpenSSL_nolink -> Qt6::OpenSSL_nolink). There is some special case code in Network autotests which tries to access the former target name, which doesn't exist when building standalone tests. Make sure to create a Qt6:: library alias for _nolink targets during a build (so before the library is exported), and change the Network autotests project to use this Qt6:: namespaced library, which will ensure it is found both in a standalone tests build and in a regular Qt build. Also make sure to actually call find_package to find the OpenSSL library when building standalone tests, otherwise configuration will fail. Change-Id: I3da5b958e72e745a50380f8ab1644459a7c6b005 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/network/CMakeLists.txt')
-rw-r--r--tests/auto/network/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/network/CMakeLists.txt b/tests/auto/network/CMakeLists.txt
index 59188717e8..b7ba3de688 100644
--- a/tests/auto/network/CMakeLists.txt
+++ b/tests/auto/network/CMakeLists.txt
@@ -9,7 +9,7 @@ if (QT_FEATURE_private_tests)
endif()
if (QT_FEATURE_openssl AND QT_FEATURE_ssl AND NOT QT_FEATURE_openssl_linked)
- include_directories($<TARGET_PROPERTY:OpenSSL::SSL_nolink,INTERFACE_INCLUDE_DIRECTORIES>)
+ include_directories($<TARGET_PROPERTY:${INSTALL_CMAKE_NAMESPACE}::SSL_nolink,INTERFACE_INCLUDE_DIRECTORIES>)
endif()
endif()
# special case end