summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-08-09 12:47:55 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-08-09 11:50:11 +0000
commit95c27e325f47cff168a85c21b4b9e592168384f9 (patch)
treec70a0f84751a43c433b3e88c49f7e6ee4e63d1de /tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
parentaaec0726234f1e7eb23087b04426591b81307e5a (diff)
Fix add_qt_resource behavior with regards to unspecified prefixes
This change makes the PREFIX parameter a required parameter if the target does not specify a default. This way the behavior is clear when reading the code: add_qt_resource() without PREFIX means it must come frmo the target. Change-Id: I79024e70e7b4d32a5164b93aa08ec9ff409b2d39 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Leander Beernaert <leander.beernaert@qt.io>
Diffstat (limited to 'tests/auto/network/access/qnetworkreply/test/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qnetworkreply/test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
index df589b67da..ae7a4d0fe0 100644
--- a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
+++ b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
@@ -35,7 +35,12 @@ add_qt_test(tst_qnetworkreply
)
# Resources:
+set_source_files_properties("../resource"
+ PROPERTIES alias "resource"
+)
add_qt_resource(tst_qnetworkreply "qnetworkreply"
+ PREFIX
+ "/"
BASE
".."
FILES