summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorVille Voutilainen <ville.voutilainen@qt.io>2019-09-09 09:08:43 +0300
committerVille Voutilainen <ville.voutilainen@qt.io>2019-09-09 10:45:21 +0000
commit1b1248d7cd2c5dc690afc356df29d41fde2ff117 (patch)
tree5a97850d3c57f54cd1355bed7d37ca476f62c716 /tests/auto/tools/CMakeLists.txt
parentbf899ba53b0407f5ef88bddb15115d4f8f03c345 (diff)
cmake: Enable building more of the tools tests
This is incomplete. moc has compilation problems, some advanced parts of qmake tests are not supported by the converter. Change-Id: Ic389ddfa10a7558f21cf7ba9ead8e58157c760da Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
new file mode 100644
index 0000000000..c546da967f
--- /dev/null
+++ b/tests/auto/tools/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Generated from tools.pro.
+
+add_subdirectory(qmakelib)
+add_subdirectory(qmake)
+#add_subdirectory(moc)
+#add_subdirectory(rcc)
+if(TARGET Qt::Widgets)
+ add_subdirectory(uic)
+endif()
+if(TARGET Qt::DBus)
+ add_subdirectory(qdbuscpp2xml)
+ add_subdirectory(qdbusxml2cpp)
+endif()