summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/moc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-02-07 18:07:56 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2022-02-09 15:33:46 +0100
commitba48e1b80909d2394636eaabaca073fc9205fdec (patch)
treee9ceab5e0a7ad0117c72eac0afbb114cf2b0dfff /tests/auto/tools/moc/CMakeLists.txt
parent1ff8877ea728bce3489168a1439b4e8bee781d39 (diff)
Add missing implicit dependencies to the tool tests
moc, qmake, rcc, and uic tests execute corresponding tools inside the test executables. This adds dependencies explicitly, to execute tests using _check targets, without the need to manually build dependencies. Pick-to: 6.3 6.2 Fixes: QTBUG-98576 Change-Id: I8b989276e21199b867591f7b0f6af9204695ac13 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Marc Mutz <marc.mutz@qt.io>
Diffstat (limited to 'tests/auto/tools/moc/CMakeLists.txt')
-rw-r--r--tests/auto/tools/moc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/tools/moc/CMakeLists.txt b/tests/auto/tools/moc/CMakeLists.txt
index 44c9ee3fa9..177615f25c 100644
--- a/tests/auto/tools/moc/CMakeLists.txt
+++ b/tests/auto/tools/moc/CMakeLists.txt
@@ -143,3 +143,9 @@ add_custom_command(TARGET tst_moc
--collect-json "@${moc_json_out}"
COMMENT "Running moc with --collect-json"
)
+
+# Add dependencies that are implicitly used inside the test
+add_dependencies(tst_moc
+ Qt::qtpaths
+ Qt::moc
+)