summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/qmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 13:03:07 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 17:25:41 +0000
commitf7d7021460d16b2b8d8ae066113668f028fe6d7c (patch)
tree080b6ad9a6a1031da63458b64e8b8d10919b7050 /tests/auto/tools/qmake/CMakeLists.txt
parent209c7238a7f4cc434f361f423a4eff0150d13dbb (diff)
Regenerate tests/auto/tools
Change-Id: I25268499ff966ebf134150accbaec7634726fe40 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'tests/auto/tools/qmake/CMakeLists.txt')
-rw-r--r--tests/auto/tools/qmake/CMakeLists.txt19
1 files changed, 15 insertions, 4 deletions
diff --git a/tests/auto/tools/qmake/CMakeLists.txt b/tests/auto/tools/qmake/CMakeLists.txt
index 23b81fe9f5..38de47f972 100644
--- a/tests/auto/tools/qmake/CMakeLists.txt
+++ b/tests/auto/tools/qmake/CMakeLists.txt
@@ -5,14 +5,12 @@
#####################################################################
# Collect test data
-
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "testdata/*")
+ testdata/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qmake
- GUI
SOURCES
testcompiler.cpp testcompiler.h
tst_qmake.cpp
@@ -25,7 +23,20 @@ add_qt_test(tst_qmake
#### Keys ignored in scope 2:.:.:qmake.pro:WIN32:
# testcase.timeout = "900"
-extend_target(tst_qmake CONDITION (CMAKE_CROSSCOMPILING) # special case
+extend_target(tst_qmake CONDITION CMAKE_CROSSCOMPILING # special case
DEFINES
QMAKE_CROSS_COMPILED
)
+
+# special case begin
+# remove this because it's not needed
+#extend_target(tst_qmake CONDITION CMAKE_BUILD_TYPE STREQUAL Debug AND debug_and_release
+ #DEFINES
+ #DEBUG_BUILD
+#)
+
+#extend_target(tst_qmake CONDITION debug_and_release AND NOT CMAKE_BUILD_TYPE STREQUAL Debug
+ #DEFINES
+ #RELEASE_BUILD
+#)
+# special case end