summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 17:51:02 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 10:06:43 +0000
commitaf72e13636eab0d294980f710a2320ed28b078ef (patch)
tree367e410122c7a9ae5de21798820952b6bbe18127 /tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt
parent3f5adb4653f964a4319c5c7364a53bb191ac8b92 (diff)
Regenerate tests/auto/widgets/graphicsview
Change-Id: I2e6a8f2f92e9cb8d6bb0be53068dfd43ba87db4c Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt22
1 files changed, 20 insertions, 2 deletions
diff --git a/tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt b/tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt
index 127e4d1d2f..b8a5fcd905 100644
--- a/tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt
+++ b/tests/auto/widgets/graphicsview/qgraphicssceneindex/CMakeLists.txt
@@ -1,6 +1,24 @@
-add_qt_test("tst_qgraphicssceneindex" SOURCES tst_qgraphicssceneindex.cpp
+# Generated from qgraphicssceneindex.pro.
+
+if(NOT QT_FEATURE_private_tests)
+ return()
+endif()
+
+#####################################################################
+## tst_qgraphicssceneindex Test:
+#####################################################################
+
+add_qt_test(tst_qgraphicssceneindex
+ SOURCES
+ tst_qgraphicssceneindex.cpp
LIBRARIES
- Qt::WidgetsPrivate
Qt::CorePrivate
Qt::GuiPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Widgets
)
+
+#### Keys ignored in scope 1:.:.:qgraphicssceneindex.pro:<TRUE>:
+# _REQUIREMENTS = "qtConfig(private_tests)"