summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/corelib/io/qfile/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-10-28 16:23:01 +0100
committerLeander Beernaert <leander.beernaert@qt.io>2019-11-04 15:48:51 +0000
commit344e4ec827ba74266454800bcd29d4a5618c0e40 (patch)
tree97b589888cb942d8993650ff254f189dcd882cbd /tests/benchmarks/corelib/io/qfile/CMakeLists.txt
parentcd9813d2763adb715d1cf1a37b86439fea255172 (diff)
Convert remaining tests/benchmarks
Change-Id: Ie7d49d4dc5bf6b2345b54f6bdfffcd974123f729 Reviewed-by: Qt CMake Build Bot Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/benchmarks/corelib/io/qfile/CMakeLists.txt')
-rw-r--r--tests/benchmarks/corelib/io/qfile/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/benchmarks/corelib/io/qfile/CMakeLists.txt b/tests/benchmarks/corelib/io/qfile/CMakeLists.txt
new file mode 100644
index 0000000000..f69f7cfca7
--- /dev/null
+++ b/tests/benchmarks/corelib/io/qfile/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from qfile.pro.
+
+#####################################################################
+## tst_bench_qfile Binary:
+#####################################################################
+
+add_qt_benchmark(tst_bench_qfile
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:qfile.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_bench_qfile CONDITION WIN32
+ DEFINES
+ _CRT_SECURE_NO_WARNINGS
+)