summaryrefslogtreecommitdiffstats
path: root/tests/manual/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2022-11-07 16:26:12 +0200
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2022-11-10 17:54:02 +0200
commite4125863f0cf2736d933e514762f898752c901e5 (patch)
tree610c0b3a84528992730086352bfa1a0288d4a0a1 /tests/manual/CMakeLists.txt
parent12a74666b76ab03b3d2cd811bbb61da7fb29cfd5 (diff)
Add permissions feature example and manual test to the build
And add license headers and some minor fixes for warnings in the example and test. Task-number: QTBUG-90498 Change-Id: I34592f7f2844c92c25a6a676c8ac1ffca9e03c6d Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Reviewed-by: Timur Pocheptsov <timur.pocheptsov@qt.io>
Diffstat (limited to 'tests/manual/CMakeLists.txt')
-rw-r--r--tests/manual/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
index 5faf171db5..182068e8e8 100644
--- a/tests/manual/CMakeLists.txt
+++ b/tests/manual/CMakeLists.txt
@@ -40,6 +40,9 @@ if (QT_FEATURE_openssl AND UNIX)
add_subdirectory(qnetworkreply)
endif()
#special case end
+if(QT_FEATURE_permissions)
+ add_subdirectory(permissions)
+endif()
add_subdirectory(qstorageinfo)
add_subdirectory(qscreen)
add_subdirectory(qscreen_xrandr)