summaryrefslogtreecommitdiffstats
path: root/tests/manual/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2011-11-01 14:59:23 +0100
committerQt by Nokia <qt-info@nokia.com>2011-11-29 17:08:39 +0100
commita482487b9ff0cf0c47f9c0927c44019d52e2fdf8 (patch)
tree71b2ae8eebdb496d7256afd82e8271fdec1dbba5 /tests/manual/cmake/CMakeLists.txt
parent57039e0891e9ee1caf2f0449b4ae7663451e6f5b (diff)
Install CMake config files from Qt.
This includes a BSD licenced file Qt5CoreMacros.cmake which is adapted from Qt4Macros.cmake in the CMake source tree. Change-Id: I54326b808795535490a0489659b351a8da72cdbb Reviewed-by: Clinton Stimpson <clinton@elemtech.com> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@nokia.com>
Diffstat (limited to 'tests/manual/cmake/CMakeLists.txt')
-rw-r--r--tests/manual/cmake/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/manual/cmake/CMakeLists.txt b/tests/manual/cmake/CMakeLists.txt
new file mode 100644
index 0000000000..b6d5f318fd
--- /dev/null
+++ b/tests/manual/cmake/CMakeLists.txt
@@ -0,0 +1,31 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(qmake_cmake_files)
+
+macro(_do_build _dir)
+ try_compile(Result ${CMAKE_CURRENT_BINARY_DIR}/${_dir}
+ ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}
+ ${_dir}
+ OUTPUT_VARIABLE Out
+ )
+endmacro()
+
+macro(expect_pass _dir)
+ _do_build(${_dir})
+ if (NOT Result)
+ message(SEND_ERROR "Build failed: ${Out}")
+ endif()
+endmacro()
+
+macro(expect_fail _dir)
+ _do_build(${_dir})
+ if (Result)
+ message(SEND_ERROR "Build should fail, but did not: ${Out}")
+ endif()
+endmacro()
+
+# Requires a patched cmake for the automoc stuff. Will uncomment when it is released.
+# expect_pass(pass1)
+expect_pass(pass2)
+expect_pass(pass3)