summaryrefslogtreecommitdiffstats
path: root/tests/manual/cmake/pass2/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-04-18 16:46:26 +0200
committerQt by Nokia <qt-info@nokia.com>2012-04-23 17:03:56 +0200
commit61c433785eb918d81b927f17bcad4687f2269afe (patch)
treebce4d94e963b4dd0f8fe73a19b5cd764a33b2627 /tests/manual/cmake/pass2/CMakeLists.txt
parentf88212c22f7e4bec261130a6f82294adfc75abca (diff)
Move the CMake unit tests to auto/
This will allow the CI system to run the tests. The tests are only run if cmake is found. Change-Id: Ie73a56114c151871160bafcbf0b90b2d54620855 Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@nokia.com> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com> Reviewed-by: Sergio Ahumada <sergio.ahumada@nokia.com>
Diffstat (limited to 'tests/manual/cmake/pass2/CMakeLists.txt')
-rw-r--r--tests/manual/cmake/pass2/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/tests/manual/cmake/pass2/CMakeLists.txt b/tests/manual/cmake/pass2/CMakeLists.txt
deleted file mode 100644
index c859f13fff..0000000000
--- a/tests/manual/cmake/pass2/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-
-cmake_minimum_required(VERSION 2.8)
-
-project(pass2)
-
-find_package(Qt5Core REQUIRED)
-
-include_directories(${Qt5Core_INCLUDE_DIRS})
-
-add_definitions(${Qt5Core_DEFINITIONS})
-
-qt5_wrap_cpp(moc_files myobject.h)
-
-qt5_add_resources(rcc_files "pass2.qrc")
-
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-
-add_executable(myobject myobject.cpp ${moc_files} ${rcc_files})
-target_link_libraries(myobject ${Qt5Core_LIBRARIES})