summaryrefslogtreecommitdiffstats
path: root/tests/manual/cmake/pass2/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2011-11-01 14:59:23 +0100
committerQt by Nokia <qt-info@nokia.com>2011-11-29 17:08:39 +0100
commita482487b9ff0cf0c47f9c0927c44019d52e2fdf8 (patch)
tree71b2ae8eebdb496d7256afd82e8271fdec1dbba5 /tests/manual/cmake/pass2/CMakeLists.txt
parent57039e0891e9ee1caf2f0449b4ae7663451e6f5b (diff)
Install CMake config files from Qt.
This includes a BSD licenced file Qt5CoreMacros.cmake which is adapted from Qt4Macros.cmake in the CMake source tree. Change-Id: I54326b808795535490a0489659b351a8da72cdbb Reviewed-by: Clinton Stimpson <clinton@elemtech.com> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@nokia.com>
Diffstat (limited to 'tests/manual/cmake/pass2/CMakeLists.txt')
-rw-r--r--tests/manual/cmake/pass2/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/manual/cmake/pass2/CMakeLists.txt b/tests/manual/cmake/pass2/CMakeLists.txt
new file mode 100644
index 0000000000..68be458cc9
--- /dev/null
+++ b/tests/manual/cmake/pass2/CMakeLists.txt
@@ -0,0 +1,11 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+find_package(Qt5Core REQUIRED)
+
+include_directories(${Qt5Core_INCLUDE_DIRS})
+
+qt5_wrap_cpp(moc_files myobject.h)
+
+add_executable(myobject myobject.cpp ${moc_files})
+target_link_libraries(myobject ${Qt5Core_LIBRARY})