summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b43a662285..d46b574369 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,9 @@ include(QtBaseGlobalTargets)
option(BUILD_SHARED_LIBS "Build Qt statically or dynamically" ON)
set(QT_BUILD_SHARED_LIBS ${BUILD_SHARED_LIBS})
+## Decide whether tools will be built.
+qt_check_if_tools_will_be_built()
+
## Visit all the directories:
add_subdirectory(src)
@@ -40,7 +43,7 @@ if (BUILD_TESTING)
add_subdirectory(tests)
endif()
-if (NOT CMAKE_CROSSCOMPILING)
+if (QT_WILL_BUILD_TOOLS)
add_subdirectory(qmake)
endif()