summaryrefslogtreecommitdiffstats
path: root/cmake/tests/features/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/tests/features/src/CMakeLists.txt')
-rw-r--r--cmake/tests/features/src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/cmake/tests/features/src/CMakeLists.txt b/cmake/tests/features/src/CMakeLists.txt
new file mode 100644
index 0000000000..bfb02be07d
--- /dev/null
+++ b/cmake/tests/features/src/CMakeLists.txt
@@ -0,0 +1,7 @@
+## Features from parent scope were inherited:
+assert(QT_FEATURE_top_a STREQUAL "ON")
+assert(QT_FEATURE_top_b STREQUAL "OFF")
+assert(QT_FEATURE_top_enabled STREQUAL "ON")
+assert(QT_FEATURE_top_disabled STREQUAL "OFF")
+assert(QT_FEATURE_top_disabled_enabled STREQUAL "OFF")
+assert(QT_FEATURE_top_not_emitted STREQUAL "OFF")