summaryrefslogtreecommitdiffstats
path: root/config.tests/separate_debug_info/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config.tests/separate_debug_info/CMakeLists.txt')
-rw-r--r--config.tests/separate_debug_info/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/config.tests/separate_debug_info/CMakeLists.txt b/config.tests/separate_debug_info/CMakeLists.txt
index 1b98c0dab0..1b38d23e25 100644
--- a/config.tests/separate_debug_info/CMakeLists.txt
+++ b/config.tests/separate_debug_info/CMakeLists.txt
@@ -1,11 +1,13 @@
-# special case skip regeneration
-cmake_minimum_required(VERSION 3.14.0)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
project(objcopytest LANGUAGES CXX)
-include(CMakeFindBinUtils)
add_executable(objcopytest main.cpp)
add_custom_command(
TARGET objcopytest
POST_BUILD
COMMAND ${CMAKE_OBJCOPY} --only-keep-debug $<TARGET_FILE:objcopytest> objcopytest.debug
COMMAND ${CMAKE_OBJCOPY} --strip-debug $<TARGET_FILE:objcopytest>
- COMMAND ${CMAKE_OBJCOPY} --add-gnu-debuglink=objcopytest.debug $<TARGET_FILE:objcopytest>)
+ COMMAND ${CMAKE_OBJCOPY} --add-gnu-debuglink=objcopytest.debug $<TARGET_FILE:objcopytest>
+ VERBATIM)