summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 81f1017dde..ade91bcef8 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -3,6 +3,10 @@
# Copy/Install doc configuration files to the build/install directory
#
qt_path_join(doc_install_dir ${QT_INSTALL_DIR} ${INSTALL_DOCDIR})
-qt_copy_or_install(DIRECTORY global DESTINATION ${doc_install_dir})
-qt_copy_or_install(DIRECTORY config DESTINATION ${doc_install_dir})
-
+foreach(dir global config)
+ qt_copy_or_install(DIRECTORY ${dir} DESTINATION ${doc_install_dir})
+ if(QT_SUPERBUILD)
+ qt_path_join(destination ${QtBase_BINARY_DIR} ${INSTALL_DOCDIR})
+ file(COPY ${dir} DESTINATION ${destination})
+ endif()
+endforeach()