summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000000..c9abbd8ec9
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,54 @@
+# special case begin
+qt_examples_build_begin()
+
+# special case end
+
+# Generated from examples.pro.
+
+add_subdirectory(corelib)
+add_subdirectory(embedded)
+add_subdirectory(qpa)
+
+if(TARGET Qt::DBus)
+ add_subdirectory(dbus)
+endif()
+
+if(TARGET Qt::Network)
+ add_subdirectory(network)
+endif()
+
+if(TARGET Qt::Test)
+ add_subdirectory(qtestlib)
+endif()
+
+if(TARGET Qt::Concurrent)
+ add_subdirectory(qtconcurrent)
+endif()
+
+if(TARGET Qt::Sql)
+ add_subdirectory(sql)
+endif()
+
+if(TARGET Qt::Widgets)
+ add_subdirectory(widgets)
+endif()
+
+if(TARGET Qt::Xml)
+ add_subdirectory(xml)
+endif()
+
+if(TARGET Qt::Gui)
+ add_subdirectory(gui)
+
+ if(QT_FEATURE_opengl)
+# add_subdirectory(opengl) # special case: removed
+ endif()
+
+ if(QT_FEATURE_vulkan)
+# add_subdirectory(vulkan) # special case: removed
+ endif()
+endif()
+
+# special case begin
+qt_examples_build_end()
+# special case end