summaryrefslogtreecommitdiffstats
path: root/examples/corelib/ipc/localfortuneclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/ipc/localfortuneclient/CMakeLists.txt')
-rw-r--r--examples/corelib/ipc/localfortuneclient/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/examples/corelib/ipc/localfortuneclient/CMakeLists.txt b/examples/corelib/ipc/localfortuneclient/CMakeLists.txt
new file mode 100644
index 0000000000..b664e5795c
--- /dev/null
+++ b/examples/corelib/ipc/localfortuneclient/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from localfortuneclient.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(localfortuneclient LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Network)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(localfortuneclient
+ client.cpp client.h
+ main.cpp
+)
+target_link_libraries(localfortuneclient PUBLIC
+ Qt::Network
+ Qt::Widgets
+)
+install(TARGETS localfortuneclient
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)