summaryrefslogtreecommitdiffstats
path: root/examples/corelib/ipc/localfortuneserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/ipc/localfortuneserver/CMakeLists.txt')
-rw-r--r--examples/corelib/ipc/localfortuneserver/CMakeLists.txt37
1 files changed, 24 insertions, 13 deletions
diff --git a/examples/corelib/ipc/localfortuneserver/CMakeLists.txt b/examples/corelib/ipc/localfortuneserver/CMakeLists.txt
index e94028413e..11fcf4e297 100644
--- a/examples/corelib/ipc/localfortuneserver/CMakeLists.txt
+++ b/examples/corelib/ipc/localfortuneserver/CMakeLists.txt
@@ -1,17 +1,28 @@
# Generated from localfortuneserver.pro.
-#####################################################################
-## localfortuneserver Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(localfortuneserver LANGUAGES CXX)
-add_qt_executable(localfortuneserver
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/ipc/localfortuneserver"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/ipc/localfortuneserver"
- SOURCES
- main.cpp
- server.cpp server.h
- LIBRARIES
- Qt::Network
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Network)
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(localfortuneserver WIN32 MACOSX_BUNDLE
+ main.cpp
+ server.cpp server.h
+)
+target_link_libraries(localfortuneserver PUBLIC
+ Qt::Network
+ Qt::Widgets
+)
+install(TARGETS localfortuneserver
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)