summaryrefslogtreecommitdiffstats
path: root/examples/corelib/serialization/savegame/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/serialization/savegame/CMakeLists.txt')
-rw-r--r--examples/corelib/serialization/savegame/CMakeLists.txt43
1 files changed, 25 insertions, 18 deletions
diff --git a/examples/corelib/serialization/savegame/CMakeLists.txt b/examples/corelib/serialization/savegame/CMakeLists.txt
index 175fca270f..637613fef8 100644
--- a/examples/corelib/serialization/savegame/CMakeLists.txt
+++ b/examples/corelib/serialization/savegame/CMakeLists.txt
@@ -1,22 +1,29 @@
# Generated from savegame.pro.
-#####################################################################
-## savegame Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(savegame LANGUAGES CXX)
-add_qt_executable(savegame
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/serialization/savegame"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/serialization/savegame"
- SOURCES
- character.cpp character.h
- game.cpp game.h
- level.cpp level.h
- main.cpp
- LIBRARIES
- # Remove: gui
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Core)
-#### Keys ignored in scope 1:.:savegame.pro:<NONE>:
-# CONFIG = "-app_bundle"
-# TEMPLATE = "app"
+add_executable(savegame
+ character.cpp character.h
+ game.cpp game.h
+ level.cpp level.h
+ main.cpp
+)
+target_link_libraries(savegame PUBLIC
+ # Remove: gui
+ Qt::Core
+)
+install(TARGETS savegame
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)