summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/threads/CMakeLists.txt')
-rw-r--r--examples/corelib/threads/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/examples/corelib/threads/CMakeLists.txt b/examples/corelib/threads/CMakeLists.txt
index b13dd16d93..670821a77d 100644
--- a/examples/corelib/threads/CMakeLists.txt
+++ b/examples/corelib/threads/CMakeLists.txt
@@ -1,9 +1,11 @@
-# Generated from threads.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-add_subdirectory(semaphores)
-add_subdirectory(waitconditions)
-
-if(TARGET Qt::Widgets)
- add_subdirectory(mandelbrot)
- add_subdirectory(queuedcustomtype)
+if(NOT ANDROID)
+ qt_internal_add_example(semaphores)
+ qt_internal_add_example(waitconditions)
+endif()
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(mandelbrot)
+ qt_internal_add_example(queuedcustomtype)
endif()