summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/threads/CMakeLists.txt')
-rw-r--r--examples/corelib/threads/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/examples/corelib/threads/CMakeLists.txt b/examples/corelib/threads/CMakeLists.txt
index fab084385f..670821a77d 100644
--- a/examples/corelib/threads/CMakeLists.txt
+++ b/examples/corelib/threads/CMakeLists.txt
@@ -1,6 +1,11 @@
-qt_internal_add_example(semaphores)
-qt_internal_add_example(waitconditions)
-if(TARGET Qt::Widgets)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+if(NOT ANDROID)
+ qt_internal_add_example(semaphores)
+ qt_internal_add_example(waitconditions)
+endif()
+if(TARGET Qt6::Widgets)
qt_internal_add_example(mandelbrot)
qt_internal_add_example(queuedcustomtype)
endif()