summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/mandelbrot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/threads/mandelbrot/CMakeLists.txt')
-rw-r--r--examples/corelib/threads/mandelbrot/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/examples/corelib/threads/mandelbrot/CMakeLists.txt b/examples/corelib/threads/mandelbrot/CMakeLists.txt
new file mode 100644
index 0000000000..00f27bacd9
--- /dev/null
+++ b/examples/corelib/threads/mandelbrot/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from mandelbrot.pro.
+
+#####################################################################
+## mandelbrot Binary:
+#####################################################################
+
+add_qt_executable(mandelbrot
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/threads/mandelbrot"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/threads/mandelbrot"
+ SOURCES
+ main.cpp
+ mandelbrotwidget.cpp mandelbrotwidget.h
+ renderthread.cpp renderthread.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(mandelbrot CONDITION UNIX AND NOT APPLE_OSX AND NOT HAIKU AND NOT INTEGRITY AND NOT VXWORKS
+ LIBRARIES
+ m
+)