summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/waitconditions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/threads/waitconditions/CMakeLists.txt')
-rw-r--r--examples/corelib/threads/waitconditions/CMakeLists.txt34
1 files changed, 22 insertions, 12 deletions
diff --git a/examples/corelib/threads/waitconditions/CMakeLists.txt b/examples/corelib/threads/waitconditions/CMakeLists.txt
index 0a347c1cdd..4d3e61050c 100644
--- a/examples/corelib/threads/waitconditions/CMakeLists.txt
+++ b/examples/corelib/threads/waitconditions/CMakeLists.txt
@@ -1,15 +1,25 @@
# Generated from waitconditions.pro.
-#####################################################################
-## waitconditions Binary:
-#####################################################################
-
-add_qt_executable(waitconditions
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/threads/waitconditions"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/corelib/threads/waitconditions"
- SOURCES
- waitconditions.cpp
-)
+cmake_minimum_required(VERSION 3.14)
+project(waitconditions LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-#### Keys ignored in scope 1:.:waitconditions.pro:<NONE>:
-# CONFIG = "-moc" "-app_bundle" "console"
+find_package(Qt5 COMPONENTS Core)
+
+add_executable(waitconditions
+ waitconditions.cpp
+)
+target_link_libraries(waitconditions PUBLIC
+ Qt::Core
+)
+install(TARGETS waitconditions
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)