summaryrefslogtreecommitdiffstats
path: root/examples/corelib/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/tools/CMakeLists.txt')
-rw-r--r--examples/corelib/tools/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/examples/corelib/tools/CMakeLists.txt b/examples/corelib/tools/CMakeLists.txt
index d25014ee3c..15188b0219 100644
--- a/examples/corelib/tools/CMakeLists.txt
+++ b/examples/corelib/tools/CMakeLists.txt
@@ -1,5 +1,7 @@
-# Generated from tools.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-add_subdirectory(contiguouscache)
-add_subdirectory(customtype)
-add_subdirectory(customtypesending)
+if(NOT TARGET Qt6::Widgets)
+ return()
+endif()
+qt_internal_add_example(contiguouscache)