summaryrefslogtreecommitdiffstats
path: root/examples/dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/CMakeLists.txt')
-rw-r--r--examples/dbus/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/examples/dbus/CMakeLists.txt b/examples/dbus/CMakeLists.txt
index 582978d5bd..79caaf949d 100644
--- a/examples/dbus/CMakeLists.txt
+++ b/examples/dbus/CMakeLists.txt
@@ -1,15 +1,16 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-if(NOT TARGET Qt::DBus)
+if(NOT TARGET Qt6::DBus)
return()
endif()
-qt_internal_add_example(listnames)
-qt_internal_add_example(pingpong)
-if(QT_FEATURE_process)
- qt_internal_add_example(complexpingpong)
+if(NOT ANDROID)
+ qt_internal_add_example(pingpong)
+ if(QT_FEATURE_process)
+ qt_internal_add_example(complexpingpong)
+ endif()
endif()
-if(TARGET Qt::Widgets)
+if(TARGET Qt6::Widgets)
qt_internal_add_example(chat)
- add_subdirectory(remotecontrolledcar)
+ qt_internal_add_example(remotecontrolledcar)
endif()