summaryrefslogtreecommitdiffstats
path: root/examples/dbus/listnames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/listnames/CMakeLists.txt')
-rw-r--r--examples/dbus/listnames/CMakeLists.txt38
1 files changed, 21 insertions, 17 deletions
diff --git a/examples/dbus/listnames/CMakeLists.txt b/examples/dbus/listnames/CMakeLists.txt
index eb622b0ef6..5fe935f24a 100644
--- a/examples/dbus/listnames/CMakeLists.txt
+++ b/examples/dbus/listnames/CMakeLists.txt
@@ -1,22 +1,26 @@
# Generated from listnames.pro.
-#####################################################################
-## listnames Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(listnames LANGUAGES CXX)
-add_qt_executable(listnames
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/dbus/listnames"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/dbus/listnames"
- SOURCES
- listnames.cpp
- LIBRARIES
- # Remove: gui
- Qt::DBus
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
-## Scopes:
-#####################################################################
+find_package(Qt5 COMPONENTS DBus)
-#### Keys ignored in scope 2:.:listnames.pro:WIN32:
-# CONFIG = "console"
+add_executable(listnames WIN32 MACOSX_BUNDLE
+ listnames.cpp
+)
+target_link_libraries(listnames PUBLIC
+ # Remove: gui
+ Qt::DBus
+)
+install(TARGETS listnames
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)