summaryrefslogtreecommitdiffstats
path: root/examples/dbus/listnames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/listnames/CMakeLists.txt')
-rw-r--r--examples/dbus/listnames/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/dbus/listnames/CMakeLists.txt b/examples/dbus/listnames/CMakeLists.txt
index ed3a55118f..a1907648b1 100644
--- a/examples/dbus/listnames/CMakeLists.txt
+++ b/examples/dbus/listnames/CMakeLists.txt
@@ -21,11 +21,21 @@ find_package(Qt6 COMPONENTS DBus)
qt_add_executable(listnames
listnames.cpp
)
+set_target_properties(listnames PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(listnames PUBLIC
Qt::Core
Qt::DBus
)
+if(WIN32)
+ set_target_properties(listnames PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ )
+endif()
+
install(TARGETS listnames
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"