summaryrefslogtreecommitdiffstats
path: root/examples/dbus/listnames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/listnames/CMakeLists.txt')
-rw-r--r--examples/dbus/listnames/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/dbus/listnames/CMakeLists.txt b/examples/dbus/listnames/CMakeLists.txt
index acc1db632c..a5a1a4b94f 100644
--- a/examples/dbus/listnames/CMakeLists.txt
+++ b/examples/dbus/listnames/CMakeLists.txt
@@ -9,7 +9,11 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/dbus/listnames")
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/dbus/listnames")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS DBus)