summaryrefslogtreecommitdiffstats
path: root/examples/dbus/pingpong/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/pingpong/CMakeLists.txt')
-rw-r--r--examples/dbus/pingpong/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/examples/dbus/pingpong/CMakeLists.txt b/examples/dbus/pingpong/CMakeLists.txt
new file mode 100644
index 0000000000..0979c8d487
--- /dev/null
+++ b/examples/dbus/pingpong/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Generated from pingpong.pro.
+
+#####################################################################
+## ping Binary:
+#####################################################################
+
+add_qt_executable(ping
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/dbus/pingpong"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/dbus/pingpong"
+ SOURCES
+ ping.cpp
+ ping-common.h
+ LIBRARIES
+ # Remove: gui
+ Qt::DBus
+)
+#####################################################################
+## pong Binary:
+#####################################################################
+
+add_qt_executable(pong
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/dbus/pingpong"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/dbus/pingpong"
+ SOURCES
+ ping-common.h
+ pong.cpp pong.h
+ LIBRARIES
+ # Remove: gui
+ Qt::DBus
+)
+
+if(WIN32)
+endif()