summaryrefslogtreecommitdiffstats
path: root/examples/dbus/remotecontrolledcar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/remotecontrolledcar/CMakeLists.txt')
-rw-r--r--examples/dbus/remotecontrolledcar/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/examples/dbus/remotecontrolledcar/CMakeLists.txt b/examples/dbus/remotecontrolledcar/CMakeLists.txt
index 4d41919962..fdca3256ad 100644
--- a/examples/dbus/remotecontrolledcar/CMakeLists.txt
+++ b/examples/dbus/remotecontrolledcar/CMakeLists.txt
@@ -1,4 +1,12 @@
-# Generated from remotecontrolledcar.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(remotecontrolledcar LANGUAGES CXX)
+
+find_package(Qt6 REQUIRED COMPONENTS Core DBus Gui Widgets)
+
+qt_standard_project_setup()
add_subdirectory(car)
add_subdirectory(controller)