summaryrefslogtreecommitdiffstats
path: root/examples/dbus/remotecontrolledcar/car/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/remotecontrolledcar/car/CMakeLists.txt')
-rw-r--r--examples/dbus/remotecontrolledcar/car/CMakeLists.txt41
1 files changed, 18 insertions, 23 deletions
diff --git a/examples/dbus/remotecontrolledcar/car/CMakeLists.txt b/examples/dbus/remotecontrolledcar/car/CMakeLists.txt
index 05960b953d..24bbdb669c 100644
--- a/examples/dbus/remotecontrolledcar/car/CMakeLists.txt
+++ b/examples/dbus/remotecontrolledcar/car/CMakeLists.txt
@@ -1,23 +1,11 @@
-cmake_minimum_required(VERSION 3.16)
-project(car LANGUAGES CXX)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/dbus/remotecontrolledcar/car")
-
-find_package(Qt6 REQUIRED COMPONENTS Core DBus Gui Widgets)
-
set(car_SRCS)
qt_add_dbus_adaptor(car_SRCS
- car.xml
+ ../common/car.xml
qobject.h
"" # empty parent_class value on purpose to not pass -l flag
car_adaptor
@@ -34,15 +22,22 @@ set_target_properties(car PROPERTIES
MACOSX_BUNDLE TRUE
)
-target_link_libraries(car PUBLIC
- Qt::Core
- Qt::DBus
- Qt::Gui
- Qt::Widgets
+target_link_libraries(car PRIVATE
+ Qt6::Core
+ Qt6::DBus
+ Qt6::Gui
+ Qt6::Widgets
)
install(TARGETS car
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION .
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)
+
+qt_generate_deploy_app_script(
+ TARGET car
+ OUTPUT_SCRIPT deploy_script
+ NO_UNSUPPORTED_PLATFORM_ERROR
)
+install(SCRIPT ${deploy_script})